+ Reply to Thread
Results 1 to 9 of 9
  1. #1
    1337
    Join Date
    May 2007
    Posts
    2,925
    Character
    aeeron
    Guild
    Reported
    Server
    Deathtoll

    Default issues with spell damage still?

    Currently an item that supposted to give +30 spell damge is only giving me +10, does anyone know why this is happening?



  2. #2
    Gnome
    Join Date
    May 2007
    Posts
    80
    Character
    Guild
    Server

    Default Re: issues with spell damage still?

    AOE spells and reactives only get 1/3 of the value.

  3. #3
    Senior Member
    Join Date
    Jul 2007
    Posts
    226
    Character
    Guild
    Server

    Default Re: issues with spell damage still?

    Quote Originally Posted by gte386v View Post
    AOE spells and reactives only get 1/3 of the value.
    should mention that for an aoe it gets 1/3 the value for every target, so if you hit 8 targets your actually getting 80 instead of 30 . Or at least that is the way I understood it.

    I thought it didn't work for reactives did they change that? I don't have any reactives lol.

    It also dosn't add that much to each dot either you just get it to the initial dot hit.

  4. #4
    1337
    Join Date
    May 2007
    Posts
    2,925
    Character
    aeeron
    Guild
    Reported
    Server
    Deathtoll

    Default Re: issues with spell damage still?

    no i have this item from the blackwater mask thats supposted to give +30 spell damage and it only seems to be +9/10 on my single target nuke



  5. #5
    ♥NINJA HUGGLES♥
    Join Date
    Dec 2006
    Posts
    6,526
    Character
    Avaela
    Guild
    Server
    360

    Default Re: issues with spell damage still?

    that's weird i just tested the same item and it adds 30 for my single target nuke

  6. #6
    Senior Member
    Join Date
    Jul 2007
    Posts
    226
    Character
    Guild
    Server

    Default Re: issues with spell damage still?

    Same here its adding 30 dammage to all my single targets

  7. #7
    Mathemagician
    Join Date
    Jan 2007
    Posts
    27
    Character
    Guild
    Server

    Default Re: issues with spell damage still?

    I haven't played for a while, so maybe this was changed; but im pretty sure that damage bonus is modified by the casting time on the spell. A longer casting time, more damage. So if youre seeing less, that might be why? I think 2.5 seconds was the break even since +.5 recovery gave 3.0 seconds total.

  8. #8
    HoOT!
    Join Date
    Aug 2007
    Posts
    148
    Character
    Guild
    Server

    Default Re: issues with spell damage still?

    Normalisation was removed so +30 would show as +30 on DD.

    Post some pics? Must be missing somethings, are you changing anything else like +int or something silly like that with the items you are swapping?

  9. #9
    1337
    Join Date
    May 2007
    Posts
    2,925
    Character
    aeeron
    Guild
    Reported
    Server
    Deathtoll

    Default Re: issues with spell damage still?

    seems to be working now, i unequipped all my BOE gear and equipped it seemed like it finally added up correctly



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Sponsor Ads